High latency and 502 errors
Incident Report for FormCrafts
Postmortem

A lot of users were experiencing high latency and some users were unable to access the forms and the dashboard. We were able to isolate and fix the issue but are still investigating the cause.

Posted Aug 14, 2023 - 04:46 PDT

Resolved
This incident has been resolved.
Posted Aug 14, 2023 - 04:31 PDT
Investigating
We are currently investigating the issue.
Posted Aug 14, 2023 - 00:29 PDT
This incident affected: Forms, Dashboard, and API.